• 为了保证你在浏览本网站时有着更好的体验,建议使用类似Chrome、Firefox之类的浏览器~~
    • 如果你喜欢本站的内容何不Ctrl+D收藏一下呢,与大家一起分享各种编程知识~
    • 本网站研究机器学习、计算机视觉、模式识别~当然不局限于此,生命在于折腾,何不年轻时多折腾一下

win64下安装机器学习库问题

Python admin 3年前 (2016-11-12) 1343次浏览 0个评论 扫描二维码

安装说明

只要确保操作系统类型、Python版本与 numpy、scipy、matplotlib 对应的版本一致 pip,wheel 环境没问题,下面就能够正常安装。

一、安装 numpy(安装 numpy-1.9.2 后,使用时发现报错,所以换了 1.10.4)

1、在 win64 python2.7 环境中,安装 numpy 会发现, 直接使用“pip install numpy”无法安装 numpy

2、我在网上找到类型的 exe 安装包,由于这个 exe 是 32 位的,安装时并没有提示错误,但使用时会报错

3、可以参照 blog:http://my.oschina.NET/HIJAY/blog/485063?fromerr=nInDlgkN,这 blog 写的很详细,但是我遇到的问题还不只这些,我之前装 pip7.x 的就已经集成有 wheel,在安装 numpy 时不需要安装这个包

4、在 http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy 中下载对应版本 win_amd64(win64)、cp27(python2.7)

5、我按照对应的操作系统(win-64)、python 版本找到地应的 numpy-1.9.2+mkl-cp27-none-win_amd64.whl 包并安装,但是由于我的 pip 7.x 下的 wheel 可能有点问题(猜的),所以导致安装还是不成功,最后升级 pip 到 8.0.3,再次安装就好了

pip install numpy-1.10.4+mkl-cp27-cp27m-win_amd64.whl

二、安装 scipy

pip install scipy-0.17.0-cp27-none-win_amd64.whl

三、安装 matplotlib

pip install matplotlib-1.5.1-cp27-none-win_amd64.whl

注意事项

即使你下载了正确的版本 whl 在安装时若出现 numpy-1.11.2+mkl-cp27-cp27m-win_amd64.whl is not a supported wheel on this platform 问题
请及时升级你的 pip 版本,升级到最新的版本就可以安装相应的 whl 了,博主我也是找了好久才发现这个坑。。。。

Deeplearn, 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明win64 下安装机器学习库问题
喜欢 (0)
admin
关于作者:
互联网行业码农一枚/业余铲屎官/数码影音爱好者/二次元

您必须 登录 才能发表评论!